Sorry, we don't support your browser.  Install a modern browser

Update VPS OS Choices#214

The OS choices are OLD (except Debian 11). Alma 8.3, Rocky 8.4, CentOS 7.9, Fedora 32.

Alma 9.0 has been out for awhile. CentOS 9 Stream would be a good addition. Fedora is currently version 36. Updates please.

4 months ago